Renewal of the EU Hub’s security certificate


As mentioned in the previous announcement regarding conforming to the latest security standards, Release 1.8 of the EU Hub will renew the EU Hub’s security certificate on Sunday, 6th December.

Although you should have the latest security standards by default, EMVO would like to remind all OBPs to check that they have the most up-to-date trusted stores (root and intermediate certificates) installed on their systems that communicate with the EU Hub.

Your administrator or IT department should be able to assist you with these checks/ updates.

EMVO recommend that you perform all required updates before the launch of Release 1.8 on Saturday, 5th December 20:00 (CET) to avoid any potential complications connecting to the EU Hub.

In the event of any questions or uncertainty, please do not hesitate to contact the EMVO Helpdesk.